Lizard Peninsula Bowmen | 2026
Resolved
Website appears to have recovered
Monitoring
The issue has been identified and it appears as though it is fasthosts issue once again.
The site appears to be recovering and requests have left the sub-10s range and fallen back into an acceptable sub-second range. The site will now be routed back to the main website, and I will continue to monitor it's recovery
Thanks for your patience and dealing with these issues
Investigating
The website has now stopped displaying the club website entirely and is instead returning error codes (most commonly 520). I am attempting to contact fasthosts to get this resolved swiftly.
The website has now been entirely re-routed to the status page.
Investigating
The website appears to be taking longer to load in places causing it to look like it is stuck or not loading. Some loads can take north of 60 seconds to complete and some do not complete at all.
An investigation is underway to find out why the load times are inflated.