Lizard Peninsula Bowmen | 2026
Resolved
Website issues should be resolved, the issue is now on the independent user
Monitoring
The server appears to be working properly now
There has been no further issues reported by the logs. If you experience any issues, please screenshot them (if possible) and email them ASAP to webadmin@helstonarchery.co.uk!
Thanks :)
Monitoring
The website appears to be back up and running, after a long chat with fasthosts, it repaired itself without us actually doing anything to the server. Since nothing was actually repaired, I will continue to monitor this over the next week.
Identified
Good morning!
Just a heads up that the website is still down, so I’ve rerouted things back to the status page for now while we sort this out.
I’ll be reaching out to Fasthosts support the moment they’re open to get this fixed properly.
What we think is going on:
Since the issue keeps coming and going rather than staying down, it looks like it’s likely related to Fasthosts’ load balancers rather than anything that’s wrong to do with us. If it was to do with us, it would have shown earlier (3-4 days ago) and wouldn’t be as intermittent.
Will keep you posted as soon as I hear back from them!
Identified
The website remains unavailable due to a fasthosts website routing error, This may not be resolved until tomorrow morning. Sorry for the inconvenience.
A temporary booking form will be delivered into the member groupchat at some point to allow members to book as normal.
Thanks for your patience!
Identified
All data within the booking system remains intact. The API is intermittently returning data successfully, indicating that the issue is not with the data itself but appears to be caused upstream of the LPB.
The email system is functioning as intended, but emails may take up to 10 minutes to deliver
Identified
The issue appears to be affecting our hosting provider, Fasthosts. We are monitoring the situation closely and waiting for the service to return to normal.
Email services have been confirmed as working; however, if your email does not send successfully, please leave it in your Sent folder and resend it once the website has resumed normal functionality.
Investigating
The website will not load pages at present, and you may see ‘This site doesn’t exist here’ or just a blank white page.
We are looking into this issue.