Lizard Peninsula Bowmen | 2026
Resolved
The website has been stable for multiple hours with no reported issues since 4pm. This should hopefully be resolved. Sorry for any issues during this period.
Monitoring
Website seems to be recovering and the load times have halved slowly over time, I will continue to monitor it's recovery.
Investigating
The website keeps crashing and returning "Connection Timed Out", We will continue to monitor this and update when the server looks to have returned to a stable state.
The website looks to be online at 4:15pm BST, and we will continue to monitor for the next few hours until the server looks to have returned to normal.
Sorry for any inconveniences caused by this outage.