Lizard Peninsula Bowmen | 2026
Complete
New fixes are in place and the booking system is operational again.
In progress
New fixes are in place and the booking system is operational again.
In progress
Reason for maintenance:
Use of the booking system has caused problems to arise that didn't appear during testing.
In progress
Maintenance has started on this component. Updates will be provided when work completes.
Scheduled
The booking system requires an update, System may go down entirely, or not function as intended during this period. This should take approximately 45 minutes.